Windows 7 + Outlook 2007 - Trogbar does not start

All,

I installed Trogar on my new Windows 7 (64 bit) OS with Outlook 2007 on it and have not been able to start it up at all. I get the following error message.

"File access is denied. You do not have the permission required to access the file C:\Users\*****"

Has any of you encountered a similar issue? Is there a fix for it?

Appreciate any help

Sri

Comments

  • This is a Windows level error. It is very unusual for any application to be denied access to the Users folder unless it is trying to write to a user folder other than the one belonging to the currently logged in user. We've never seen this before with Trog Bar. Some possible causes that I can think of:
    1. Windows may sometimes log you into the "Default" account if your user profile was corrupted. If so, it should have warned you about this. It is possible that logging into the default account might cause a problem like this.
    2. This could probably happen if an administrator changed the permissions on the file, or any of the directories leading to the file. For most software (including Trog bar) to work, the currently logged in user will need, at least, both read and write access to their account's AppData directory, and everything inside it.
    3. It is possible that another application set a write lock on the file. If so, rebooting might help.
    Other than that, there's not much I can tell you. It would be very helpful to know exactly which file access was denied to.
  • The file in question is Appdata\Local\Microsoft\Outlook\outlook.ost. My account has read and write permissions on it. The only other process that could potentially lock the file is outlook itself and I don't have it running. Also tried a reboot
  • Usually I would say that any error that gives this message is UAC related, but in theory that should be a non-issue for your user account folder.

    Am I correct in assuming that this is in your user folder? (Accessing other users' folders likely will create problems.)

    Please try the following and let me know if either of them work:
    1. Run Trog Bar as an administrator
    2. Disable UAC (Method #2 at http://www.petri.co.il/disable_uac_in_windows_vista.htm is the easiest way)
    Do either of these prevent the problem?

    Just to be clear, neither of the above should be required, because Windows is not supposed to restrict access to a user's own AppData location. I'm just trying to get a handle on what the problem is, or isn't.
  • Solved it. Nothing to do with TrogBar as you said.

    Essentially I had a security agent installed on my laptop that was preventing the Trogbar app from accessing the outlook.ost file. I added an exception and now everything works as expected.

    Appreciate the help
  • edited December 2010

    I had this happen because I had Outlook 2010 x64 installed.   Uninstalled and installed x86, it was fine.

     Well... sorta.   Now my Outlook search indexing is busted.

     /kenw

  • Yes, at the API level there's a huge difference between 64 bit and 32 bit Outlook. Trog only works with 32 bit. Perhaps you have another program installed that only works with 64 bit? (That's the only explanation I can think of for the indexing problem.)
Sign In or Register to comment.